InfoDB API V2 läuft aus – Änderung auf V3 für ältere PHPFox Versionen

Betreiber von PHPFox Versionen bis 3.5.1 die den kostenlosen Service von InfoDB zur Lokalisierung der Mitglieder nutzen, tun dies momentan nur über die API v2 vom Hersteller. Die V2 Schnittstelle wird von InfoDB am 31. Oktober 2013 eingestellt und durch V3 ersetzt. PHPFox hat erst ab Version 3.6.0 den API Aufruf umgestellt. Einige Betreiber haben mit der Version 3.5.1 eine stabile Version ihrer Community am laufen und möchten den Core nicht aktualisieren, den Service von InfoDB aber weiterhin nutzen.

Durch einen Core-Edit kann man diesen API Aufruf leicht ändern. Wie immer gilt: VORHER ein Backup der entsprechenden Datei machen.

Sucht folgende Datei: phpfoxroot/module/core/include/service/core.class.php und in dieser Datei nach:

Ersetzt diese Zeile durch:

Sucht folgende Datei: phpfoxroot/include/library/phpfox/locale/locale.class.php und in dieser Datei nach:

Ersetzt diese Zeile durch:

Durch diese 2 Änderungen sollte der Service von InfoDB dann wieder nutzbar sein ohne auf eine neuere PHPFox Version umzusteigen. Denkt an ein Backup vor den Änderungen!